Crea sito

Esercizio: somma

Abbiamo visto, precedentemente, come si utilizza la funzione Somma. Adesso facciamo un esercizio per fissare meglio il concetto.

Calcoliamo, nella tabella creata nel foglio Spese 2014, il totale per i mesi dell'anno e per i tipi di spesa. Iniziamo calcolando il totale delle spese sostenute nel mese di gennaio. Spostiamoci nella cella F3, e clicchiamo sul pulsante Somma, presente nella Barra di calcolo. L'intervallo di celle, di cui il programma “pensa” che vogliamo calcolare la somma, viene contornato da un bordo blu. Infatti viene calcolata la somma del contenuto delle quattro celle (intervallo B3:E3) che si trovano alla sinistra della cella in cui vogliamo inserire il totale. La formula è: =SOMMA(B3:E3). Questo è un punto molto importante per capire come funziona la composizione delle formule, in particolare della formula della somma

Calcolo spese del mese di gennaio

Figura 55. Calcolo spese del mese di gennaio

 

A questo punto, controlliamo, anche osservando la formula, se l'intervallo, che è stato inserito automaticamente è corretto. Se l'intervallo contiene, effettivamente, i riferimenti alle celle di cui desideriamo sommare il contenuto, premiamo il tasto INVIO. La cella attiva diventa la cella sottostante e in automatico viene calcolata la somma che è 595

Totale spese del mese di gennaio

Figura 56. Totale spese del mese di gennaio

 

Calcoliamo il totale delle spese del mese di febbraio, inserendo il risultato nella cella F4. Ancora una volta, viene calcolata la somma delle quattro celle che si trovano alla sinistra della cella in cui vogliamo inserire il totale e la cella attiva diventa la cella F5.

Continuiamo, in questo modo, a calcolare i totali per tutti i mesi dell'anno

Totale dei mesi

Figura 57. Totale dei mesi

 

Spostiamoci ora nella cella B15 e iniziamo a calcolare i totali in base alla tipologia di spesa. Questa volta l'intervallo selezionato (B3:B14) non contiene più le quattro celle a sinistra della cella selezionata, ma le celle soprastanti la cella che abbiamo selezionato, in cui appare la formula (=SOMMA(B3:B14)) e in cui verrà inserito il totale delle spese per l'energia elettrica

Calcolo spese per tipologia

Figura 58. Calcolo spese per tipologia

 

Continuiamo il calcolo dei totali, per tipologia di spesa, e inseriamo, nella cella F15, il totale dei totali che, sia che venga calcolato in base all'intervallo di celle nella riga o all'intervallo di celle nella colonna darà lo stesso risultato (8146)

Totale spese per tipologia

Figura 59. Totale spese per tipologia

 

Disponendo i dati su una tabella e analizzandola riusciamo a rispondere alle seguenti domande:

  • in quale mese dell'anno abbiamo speso di più? (Dicembre);
  • per quale tipologia abbiamo speso di più? (Cibo);
  • per quale tipologia e in quale mese abbiamo speso di più? (Cibo, Dicembre)

Analisi della tabella

Figura 60. Analisi della tabella

 

17 Formattare una tabella

Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie. Se vuoi saperne di più o negare il consenso a tutti o ad alcuni cookie vai alla sezione Cookie policy cliccando sull'apposito pulsante