Crea sito

Riferimenti assoluti

I riferimenti assoluti vengono utilizzati per far riferimento, in modo assoluto, ad una o più celle. In pratica i riferimenti assoluti alle celle, presenti in una formula, non si aggiornano in base alla cella in cui viene inserita la formula, come per le formule dove sono presenti dei riferimenti relativi, ma si riferiscono sempre alle celle indicate. Vediamo un esempio.

Selezioniamo il foglio Spese 2014 bis. Ricordiamo che per calcolare i totali, nelle due tabelle, sono stati utilizzati i riferimenti relativi cioè quei riferimenti in cui il riferimento alle celle, nella formula, cambia in base alla cella in cui viene copiata la formula (fissiamo bene il concetto!!!).

Vogliamo calcolare il totale di ciò che abbiamo speso nel 2013 e nel 2014. Selezioniamo la cella A35 e digitiamo Spesa 2013. Inseriamo nella cella B35 Spesa 2014. Inseriamo nella cella C35 Totale. Copiamo nella cella A36 il totale del 2013 (cella F32, valore 6946) e nella cella B36 il totale del 2014 (cella F15, valore 8146)

Errori di riferimento

Figura 164. Errori di riferimento

 

Naturalmente, abbiamo l'errore #RIF! Se selezioniamo la cella B36, che contiene il totale delle spese del 2014, e osserviamo la formula nella Riga di digitazione, vediamo che i riferimenti alle celle non sono corretti (vengono cercati i valori nelle quattro celle a sinistra, ma non sono esistenti)

Formula nella cella B35

Figura 165. Formula nella cella B36

 

Per risolvere questo problema dobbiamo utilizzare i riferimenti assoluti. Con l'utilizzo dei riferimenti assoluti, nella formula si fa riferimento sempre al contenuto delle stesse celle, anche se si copia la formula in altre celle. Per creare un riferimento assoluto bisogna anteporre il simbolo $ (dollaro) davanti al riferimento della cella. Spostiamoci nella cella F32, dove appare il totale del 2013 e creiamo dei riferimenti assoluti inserendo il simbolo $ alla sinistra dell'intestazione della colonna della prima cella dell'intervallo e inserendo il simbolo $ alla sinistra dell'intestazione della riga della prima cella dell'intervallo. Inseriamo poi il simbolo $ alla sinistra dell'intestazione della colonna dell'ultima cella dell'intervallo e inseriamo il simbolo $ alla sinistra dell'intestazione della riga dell'ultima cella dell'intervallo. La formula aggiornata sarà: =SOMMA($B$32:$E$32)

Inserimento di riferimenti assoluti

Figura 166. Inserimento di riferimenti assoluti

 

Quando abbiamo terminato digitiamo INVIO. Creiamo dei riferimenti assoluti anche nella cella F15 che contiene la formula per calcolare il totale del 2014. La formula aggiornata sarà: =SOMMA($B$15:$E$15). D'ora in poi, in qualsiasi cella inseriamo la formula, si farà riferimento sempre all'intervallo di celle contenute in essa.

Cancelliamo i valori presenti nelle celle A36 e B36. Il valore del totale del 2013, presente nella cella F32, lo copiamo nuovamente nella cella A36 e il valore del totale del 2014, presente nella cella F15, lo copiamo nella B36. Ora, se osserviamo i valori copiati vediamo che sono corretti, perché i riferimenti sono assoluti cioè la cifra si riferisce ad un'operazione su un intervallo di celle preciso, quello indicato nella formula

Riferimento assoluto

Figura 167. Riferimento assoluto

 

Inseriamo nella cella C36 il totale utilizzando la funzione Somma

Spesa totale

Figura 168. Spesa totale

 

28.2.1 Esercizio sui riferimenti assoluti

Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie. Se vuoi saperne di più o negare il consenso a tutti o ad alcuni cookie vai alla sezione Cookie policy cliccando sull'apposito pulsante