Crea sito

Riferimenti relativi

I riferimenti relativi sono quelli in cui i riferimenti alla celle, presenti in una formula, si aggiornano in base alla cella in cui si trovano.

Quando utilizziamo i riferimenti relativi, le celle vengono indicate utilizzando solamente l'intestazione della colonna e l'intestazione della riga. Quelli che abbiamo utilizzato sino ad ora sono quindi i riferimenti relativi. Per capire meglio questo concetto vediamo un esempio.

Lavoriamo sul foglio Spese 2014 bis. Eliminiamo i valori dei totali, presenti nell'intervallo di celle F3:F15;B15:E15. Inseriamo nuovamente il valore dei totali, ma questa volta in modo differente. Quando abbiamo calcolato i totali, nella tabella originale, lo abbiamo fatto posizionandoci su ciascuna cella, in cui dovevamo inserire il totale, e utilizzando il pulsante Somma. Iniziamo quindi posizionandoci sulla cella F3 e calcoliamo il totale del mese di Gennaio, utilizzando il pulsante Somma. La formula della cella F3 è =SOMMA(B3:E3). Il programma fa la somma del contenuto delle quattro celle che si trovano alla sinistra della cella in cui dobbiamo inserire il totale

Totale spese mese Gennaio

Figura 158. Totale spese del mese di Gennaio

 

Premiamo il tasto INVIO e otteniamo il totale. Facciamo un copia e incolla del contenuto della cella F3 nella cella F4. Che cosa può accadere? Che numero verrà inserito nella cella F4? Il numero 595 contenuto nella cella F3? La risposta è che viene inserito il numero 629 che è il totale, cioè il valore della somma, del contenuto delle quattro celle che si trovano alla sinistra della cella in cui viene inserito il totale (F4). Quindi viene inserito il totale delle spese del mese di Febbraio

Totale spese mese Febbraio

Figura 159. Totale spese del mese di Febbraio

 

Osservando la formula =SOMMA(B4:E4), presente nella barra della formula, deduciamo che si è adattata al nuovo intervallo di celle. Questo perché, la formula iniziale, conteneva dei riferimenti relativi. Inseriamo il totale per tutti i mesi, ripetendo il comando Incolla nell'intervallo di celle F5:F14. Osserviamo come il riferimento alle celle, presente nella formula, cambia in base alla posizione della cella in cui deve apparire il totale.

Se ripetiamo l'operazione anche nella cella F15 il risultato sarà 0. Infatti il programma somma il valore delle quattro celle che si trovano a sinistra della cella in cui deve apparire il totale, come possiamo vedere dalla formula, ed essendo queste celle vuote, il totale sarà 0

Calcolo totali

Figura 160. Calcolo dei totali

 

Posizioniamoci nella cella B15, per calcolare il totale della spesa per l'energia elettrica e ripetiamo la funzione Incolla. Anche in questo caso non otteniamo un numero ma un messaggio di errore: #RIF!

Errore di riferimento

Figura 161. Errore di riferimento

 

Questo messaggio indica che il riferimento alle celle, utilizzato nella formula è sbagliato. Infatti il programma cerca di fare la somma dei valori che sono contenuti nelle quattro celle a sinistra della cella in cui deve apparire il totale, cosa impossibile perché, a sinistra, non sono presenti quattro celle, ma solamente una che, tra l'altro, contiene del testo. Dobbiamo quindi cliccare sul pulsante Somma, selezionare, con il mouse, l'intervallo corretto (B3:B14) e premere il tasto INVIO

Totale spesa energia elettrica

Figura 162. Totale spesa energia elettrica

 

Facciamo poi copia del contenuto della cella B15 e lo incolliamo nelle celle C15, D15, E15. Premiamo il tasto ESC sulla tastiera per indicare al programma che abbiamo terminato l'operazione di Incolla. Se osserviamo le formule delle celle C15, D15, ed E15 vediamo che i riferimenti alle celle si sono adattati alla posizione in cui è stata incollata la formula proprio perché abbiamo utilizzato i riferimenti relativi

Riferimenti relativi

Figura 163. Riferimenti relativi

 

28.2 Riferimenti assoluti

Questo sito utilizza cookie, anche di terze parti, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all’uso dei cookie. Se vuoi saperne di più o negare il consenso a tutti o ad alcuni cookie vai alla sezione Cookie policy cliccando sull'apposito pulsante